
XSI VBS Tutorial 

 

SOFTIMAGE¦XSI SDK Scripting(VBS)チュートリアル 

 

準備 

 
1. スクリプトに関する情報が以下のサイトから得られます。VBSのマニュアルもこちらから
入手できますのでダウンロードしてインストールしておくと良いでしょう。 
http://www.microsoft.com/japan/developer/scripting/ 

2. NetViewページ作成のために HTMLエディタ（FrontPageなど）があると便利です。 
3. スクリプトのグローバル設定を行います。 

File – User Preferenceにて、Scripting/Loggingタブをクリックします。 
使用するスクリプト言語、ログサイズ、ログファイルを設定します。 
本チュートリアルでは、”VB Script Language”を用いますので、Scripting Language
を”VB Script Language”に設定して下さい。他はデフォルトで結構です。 

 
 

オンラインマニュアルの参照方法 

 
Script エディタを開き、コマンドバーのヘルプアイコン（？）をクリックします。Programmer’s 
Reference を参照すると使用可能なコマンド群の一覧がデフォルト HTML ブラウザで表示さ
れます。 
 
Commands 
SOFTIMAGE|XSIのスクリプト内で使える XSIネイティブの command群 
 
Objects 

Methods（関数に相当）や Properties（変数に相当）から構成されるプログラミング構造体 
 
Methods 

 
Properties 

 
Constants 
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XSI VBS Tutorial 

 
※Tutorial 1,Tutorial 2については、DKN_MyTools.xsiaddonをインストールして下さい。 
 

Tutorial 1：ヒストリからのスクリプトボタンの作成 

 
変形済みの Sphereが Getできるスクリプトボタンを作成してみましょう。 
 
ヒストリからのスクリプトボタンの作成 
1. スクリプトエディタアイコン（または Alt + 4）をクリックして、Scriptエディタを開き
ます。 

   
2. Edit > Clear History Logを選択してヒストリをクリアします。 
3. Get > Primitive > Surface > Sphereを選択し、Sphereを取り出します。 
  この時、ヒストリには、以下のように表示されます。 
  CreatePrim “Sphere” , “NurbsSurface” 
4. sphereプロパティページにて、Radius, U Subdivision, V Subdivisionの値を変更してみ
ます。ヒストリには、SetValue コマンドとプロパティが表示され、値が設定されている
のが分かります。 

5. M キーを押しながら、任意のビューでポイントを移動させてみます。ヒストリには、
Translateコマンドが表示されています。ある程度、形状を変えてみて下さい。 

 
6. View > Custom Toolbars > New Toolbarを選択し、ツールバーの名前を”MyTools”と入力
し、OKをクリックします。新しいツールバーが開きました。 
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7. ヒストリから、CreatePrim から Translate の最後の行までを選択し、ツールバーまでド
ラッグ＆ドロップします。 

8. Add Script Command プロパティエディタが開きますので、Command/Button Name
に”DefSphere”、Script Command Nameにも”DefSphere”と入力します。 

  注：必要があれば、Filename にもファイル名を設定して下さい。デフォルトでセーブさ
れるディレクトリは、C:¥users¥<username>¥Softimage¥XSI_<Ver.No>¥Data¥Scripts
になります。 

 

 
 
9. OKをクリックすれば、MyToolsに DefSphereボタンが登録されます。 
10. ここで、登録した DefSphere ボタンをクリックしてみましょう。恐らく、新しい球が表
示されると思いますが、変形は行われていません。これは、既にシーン内に Sphereとい
う名前が存在しているため、新しい球の名前が Sphere1になってしまっているからです。
試しに、Edit > Delete Allとした後に、DefSphereをクリックしてみて下さい。今度は、
変形まで行われた球が取り出せたはずです。次のステップでは、この Scriptを編集し、汎
用的に使えるようにしましょう。 

 
スクリプトの編集 
11. DefSphereボタンを右クリックし、Edit Scriptを選択します。Scriptエディタに内容が
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表示されます。 
12. CreatePrim行の下に以下の行を追加します。 
  set ob = GetValue(“SelectionList”)(0) 

説明：GetValue は SOFTIMAGE|XS が提供しているコマンドです。引数は取り出した
いパラメータですが、ここでは”SelectionList”を指定することにより、選択されているオ
ブジェクト、コンポーネント、パラメータなどを取り出すことができます（CreatePrim直
後は自動的に選択状態になっています）。”SelectionList”は、Collection（オブジェクトの
配列 - XSIのスクリプトマニュアル、Con ept &Techniques for Developers – Selecting 
through Scriptingを参照）であり、複数のオブジェクトを含むことが可能なので、さらに
(0)を指定して、最初のアイテムだけを取り出し、obに代入しています。GetValueの仕様
や使用例については、Script Editor の”? をクリックして XSI の持つコマンド群から参照
することができます。 

I

c s

”

13. Translate行と SetValue行を以下のように変更します。 
  SetValue “sphere.sphere.radius”, XXX 

          ↓ 

  SetValue ob&”.sphere.radius”, XXX 

 

  Translate “sphere.pnt[(X,X)]”, XXX, XXX, XXX, siRelative, siView, siObj, siXYZ 

          ↓ 

  Translate ob&“.pnt[(X,X)]”, XXX, XXX, XXX, siRelative, siView, siObj, siXYZ 
  説明：&は文字列連結演算子です。obの名前と連結できます。 
14. File > Saveにてセーブし、再度、DefSphereをクリックしてみて下さい。今度は変形し
た球が取り出せたはずです。 

 
ヒント： 

z 上記の例では、SelectionListを用いて明示的に選択されたアイテムを得ましたが、
多くの XSI コマンドではデフォルトは選択されているアイテムを対象にしてい
ます。従って、対象を明示せずに以下のように省略して記述することも可能です。 
  SetValue ”.sphere.radius”, XXX 

Translate “.pnt[(X,X)]”, XXX, XXX, XXX, siRelative, siView, siObj, siXYZ 
z Script エディタ内で、XSI コマンドを選択し、F1 キーを押すとそのコマンドの

Helpが素早く呼び出せます。 
z Script エディタの Run をクリックすることにより、スクリプトを直接実行でき
ます。また、F5キーでも Scriptの実行、CTRL+BREAKにて中断が行えます。 

z 実行したくない部分は ‘ にてコメントアウトできます。また、行を選択し、Run
をクリックすればその行のみ実行されます。 

z Script で実行したことは、通常の操作と同じように Undo/Redo ができます。
(CTRL+Z/CTRL+Y) 

z File > Keyboard Mapping にてカスタムコマンドをキーにマッピングすること
が可能です。Groupから Custom Script Commandsを選択すれば、カスタムコ
マンドの一覧が表示されますので、コマンドを選択し、キーボード上にドラッグ

＆ドロップすれば登録されます。 
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Tutorial 2：ジオメトリ情報の出力 

 
オブジェクトのジオメトリを書き出してみましょう。 
 
書き出すファイル名を指定する入力ボックスの作成 
1. スクリプトエディタアイコンをクリックして、Script Editorを開きます。 
2. Edit > Clear History Logを選択してヒストリをクリアします。（エディタ領域に文字が
残っていれば、Edit > Clear Script Editorも実行して下さい） 

3. ファイル名を指定する入力ボックスを作ってみましょう。以下のようにコードを書きます。 
filename = InputBox(“Please input Filename”,”Filename”,”C:¥temp¥geom.txt”) 

説明：InputBoxは VBS側で提供している文字入力ダイアログボックスです。第１引数は
メッセージ、第２引数はタイトル、第３引数はデフォルト値を表しています。その他にも

表示位置なども指定できますので詳細は VBSの参考書などで調べてみて下さい。 
4. “Run”をクリックしてみます。文字入力ダイアログボックスが表示されました。この段階
では、単なる文字列なので、まだファイル名としては認識されていません。”OK”を押して
そのまま終了させます。 

 

説明：この後のチュートリアルで、さらに XSIのダイアログを使ったり、ファイルブラウ
ザなどを用いる例が出てきます。 

5. エラートラップを付けて、filename に文字列が入っているときのみ本体のプロシージャ
(OutValue)が呼ばれるようにします。以下のようにコードを追加します。 
  If filename <> "" then 

 Call OutValue( filename ) 

End If 
6. プロシージャ OutValueを記述します。先ず、ファイルを扱えるようにするにはファイル
システムのオブジェクトを作成する必要があります。以下のようにコードを追加してみて

下さい。 
Sub OutValue( filename ) 

Set FS = CreateObject(“Scripting.FileSystemObject”) 

Set FT = FS.CreateTextFile( filename ) 

  End Sub 
説明：CreateObject にて、オートメーションオブジェクトを作成します。オートメーシ
ョンオブジェクトとは、オートメーションインタフェースによって他のアプリケーション

やプログラミングツールに公開されるオブジェクトで、CreateObject 関数を使用するこ
とによって、そのアプリケーションを起動したり、機能を呼び出したりできます。第１引

数はアプリケーション名、第２引数はクラスです。ここでは、Scripting（この場合はWSH
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の VBS）というアプリケーションの FileSystemObjectというオブジェクトのクラスを作
成しています。その後、Set にてオブジェクトへの参照を変数 FS に代入します。
CreateTextFile は、FileSystemObject が持つメソッドと呼ばれるもので、ファイル（フ
ァイル名：”filename”）を作成し、Te tSt amオブジェクトを返します。Te tStr mオ
ブジェクトは FTに代入され、実際に読み書きする際に使用されます。 
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CreateObject 関数、FileSystemObject、CreateTextFile メソッドなどは Microsoft 社の
提供する VBScriptドキュメントや市販の VBSの参考書などで調べることができます。 

 
選択されているモデルのジオメトリ情報の取得とファイル出力 
7. 選択されているモデルの情報を取り出してみます。続けて OutValueプロシージャ内に以
下のコードを追加してみて下さい。 
Set mySelList = GetValue(“SelectionList”) 

説明：Tutori l 1と同様に GetValue(“SelectionList”)にて選択されているアイテムを取り
出します。この段階では、mySelLis には複数のアイテムが含まれている可能性があるこ
とに注意して下さい。 

8. 選択されたアイテム数分のループを作り、それぞれの頂点数をファイル出力してみましょ
う。さらにOutValueプロシージャ内に以下のコードを追加します。何かモデルを作成し、
選択状態にした後、Runしてみて下さい。C:¥temp¥geom.txtに頂点数が出力されていれ
ば成功です。 
If mySelList.count > 0 Then 

 For i = 0 to mySelList.count ‐  1 

  Set myItem = mySelList.item( i ) 

  Set myGeometry = myItem.obj 

  myNumberOf0DGeometries = myGeometry.Nb0D 

  FT.WriteLine( myNumberOf0DGeometries ) 

 Next 

Else 

 res = MsgBox(“Nothing Selected.”, 16) 

End If 
説明： If ～  Then ～  Else ～  End If は、条件によって処理を分岐させます。
mySelList.countは mySelListに含まれているアイテム数を参照し、mySelList.item( i )
にて実際のアイテムを取り出します。さらに myItem.obj にてジオメトリオブジェクトを
取り出し、myGeometry.Nb0Dにて”0D”ジオメトリ数（頂点数）を取り出します（XSIの
ス ク リ プ ト マ ニ ュ ア ル 、 Programme ’s Reference – Prope ties – 
Item(SIObjectCollection), Prop ties – Obj(Collection tem), Properties – 
Nb0D(Geometry_V1)を参照）。 
W iteLineは、TextStre mオブジェクトの持つメソッドで、文字列と改行文字を書き込み
ます。（VBSマニュアルを参照） 
mySelList.count > 0でなければ” No hing Selected. というメッセージボックスが表示さ
れます。MsgBox関数は VBS側で用意されている関数で、メッセージダイアログボックス
を表示させます。第１引数はメッセージの内容を、第２引数でボタンの種類や個数などを

指定できます。（VBSマニュアルを参照） 
9. さらに頂点座標を取り出してみましょう。FT.WriteLine( myNumberOf0DGeometries )
の後に以下の行を追加してみて下さい。 

  ダイキン工業株式会社 電子システム事業部 6 



XSI VBS Tutorial 

Set my0DGeometry = myGeometry.Geometry0D 

Set myPos = xsimath.CreateVector3 

For j = 0 to myNumberOf0DGeometries ‐  1 

 my0DGeometry.Position j, myPos  

 FT.WriteLine( myPos.x & “ “ & myPos.y & “ “ & myPos.z ) 

Next 
説明：myGeometry.Geometry0D にて 0D ジオメトリを取り出します。次に頂点座標を
ストアするオブジェクトを作成します。適切なデータ形式でストアするために、XSI側の
Math Classで提供されているオブジェクト“xsimath.CreateVector3”で、x,y,zの倍精度ベ
ク タ ー 型 の オ ブ ジ ェ ク ト myPo を 確 保 し ま す 。 さ ら に 、 頂 点 数 分
（myNumbe Of0DGeometries）のループで、my0DGeometry.Position j, myPos にて、
j番目でインデクスされる、頂点データがmyPos内に得られ、myPos.x, myPos.y, myPos.z
にて実際の頂点座標が得られます。 （XSI のスクリプトマニュアル、Properties – 
Geometry0D、Methods – Position(Geometry0D)、Class Hierarchy of the XSI Object
Model – Math Classes - SIVector3 – Properties – X/Y/Zを参照） 

s
r

 

FT.WriteLine( myPos.x & “ “ & myPos.y & “ “ & myPos.z )の&は文字列連結演算子です。 
10. Run をクリックし、正常な動作が確認できたら、Edit > Select All にて全てを選択し、

MyToolsツールバーにドラッグ＆ドロップします。 
11. Add Script Command プロパティエディタが開きますので、Command Name
に”GeomOut”、Command Name For Scriptingにも”GeomOut”と入力します。 
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  注：必要があれば、Filename にもファイル名を設定して下さい。デフォルトでセーブさ
れるディレクトリは、C:¥users¥<username>¥ Softimage¥XSI_<Ver.No>¥Data¥Scripts
になります。 

12. OK をクリックすれば、MyTools に GeomOut ボタンが登録されます。GeomOut ボタン
をクリックして最終的な動作確認を行ってみて下さい。 

 
 
GeomOut.vbsスクリプトの中身 
 
filename = InputBox("Please input Filename","Filename","C:¥temp¥geom.txt") 

If filename <> "" Then 

 Call OutValue( filename ) 

End If 

 

Sub OutValue( filename ) 

 Set FS = CreateObject("Scripting.FileSystemObject") 

 Set FT = FS.CreateTextFile( filename ) 

 Set mySelList = GetValue("SelectionList") 

 If mySelList.count > 0 Then 

  For i = 0 to mySelList.count - 1 

   Set myItem = mySelList.item( i ) 

   Set myGeometry = myItem.obj 

   myNumberOf0DGeometries = myGeometry.Nb0D 

   FT.WriteLine( myNumberOf0DGeometries ) 

   Set my0DGeometry = myGeometry.Geometry0D 

   Set myPos = xsimath.CreateVector3 

   For j = 0 to myNumberOf0DGeometries - 1 

    my0DGeometry.Position j, myPos 

    FT.WriteLine( myPos.x & " " & myPos.y & " " & myPos.z ) 

   Next 

  Next 

 Else 

  res = MsgBox("Nothing Selected.", 16) 

End If 

End Sub 

 

※さらに余裕があれば、その他の情報の出力ルーチンやエラートラップなどもインプリメント

してみて下さい。 
 
カスタムダイアログの作成 
13. VBSで用意している InputBoxではなく、XSIが用意しているカスタムダイアログに変更
してみましょう。以下のように変更してみて下さい。変更前の行は ’ にてコメントにして
おくと良いでしょう。 
filename = InputBox("Please input Filename","Filename","C:¥temp¥geom.txt") 

  ダイキン工業株式会社 電子システム事業部 8 



XSI VBS Tutorial 

If filename <> "" Then 

 Call OutValue( filename ) 

End If 

   ↓ 
SIAddProp "Custom_parameter_list", "Scene_Root", , "Filename_param" 

SIAddCustomParameter "Scene_Root.Filename_param", "Filename", siString 

SetValue "Scene_Root.Filename_param.Filename", "C:¥temp¥geom.txt" 

On Error Resume Next 

InspectObj  "Scene_Root.Filename_param",,,siModal 

If Err.Number = 0 Then 

 filename = GetValue( "Scene_Root.Filename_param.Filename" ) 

 Call OutValue( filename ) 

End If 

DeleteObj "Scene_Root.Filename_param" 
  説明：SI_AddPropコマンドとSIAddCustomParameterコマンドは、XS の持つカスタムパ
ラメータ(Animate > Create > Parameter > New Custom Parameter Set と New Custom 
Parameter) で、使用されます。ここでは、Scene_Rootノードの真下にFilename_paramプロ
パティを持つカスタムパラメータプロパティページを作成しています。SetValueコマンドにて、
デフォルト値を与え SIAddCustomParameterの引数でデフォルト値を与える方法もあり
ます)、InspecObjコマンドにて、プロパティページを開いています。プロパティページにて”OK”
がクリックされれば、Err.Numberが０になって返ってくるので（XSIのスクリプトマニュア
ル、CommandsのInspectObjを参照）、GetValueコマンドで入力されたファイル名をfilename
に代入し、プロシージャを呼び出します。最後に、DeleteObjコマンドにて不要になったカスタ
ムパラメータプロパティページを削除しています。 

I

(

14. Run にて実行してみて下さい。XSI のカスタムダイアログで入力できるのを確認したら、
File > Saveにてセーブして下さい。 

 

 
ファイルブラウザを使用する 
15. VBSにて提供されている common dialog control (mscomdlg.commondialog)を用いれば、
ファイルブラウザを用いることができます。プロシージャ Sub OutValue( filename )～ 
End Sub以外は全てコメントアウトし、以下のコードを追加してみて下さい。 
Set DLG = CreateObject("mscomdlg.commondialog") 

DLG.Filter = "Text Files (*.txt)|*.txt|All Files (*.*)|*.*" 

DLG.MaxFilesize = 128 

  ダイキン工業株式会社 電子システム事業部 9 



XSI VBS Tutorial 

DLG.Filename = "geom..txt" 

DLG.Showopen 

If DLG.FileName <> "" Then 

 Call OutValue( DLG.FileName ) 

End If 

16. Run にて実行してみて下さい。ファイルブラウザが使用できるのを確認したら、File > 
Saveにてセーブして下さい。 

 
 

 
ヒント：DLG.Filter を設定すれば、ファイルの拡張子によるフィルタが使用できます。
ブラウジング時に“ファイルの種類”から拡張子を選択すれば、不要なファイルをフィル

タリングできます。 
 
グローバルコードを含まない Scriptの登録 
17. プロシージャのみを含む Scriptを登録し、プロシージャの引数を実行時に与えるようにし
ましょう。今度は、別のカスタムボタンとして登録してみます。Scriptエディタからプロ
シージャ Sub OutValue( filename )～ End Subを選択し、ツールバーにドラッグ＆ドロ
ップして下さい。Add Script Commandダイアログが開きます。 

18. 以下のように入力します。 
Command Name：GeomOutProc 
Command Name For Scripting：GeomOutProc 
Filename：C:¥users¥<username>¥Softimage¥XSI_<Ver.No>¥Data¥Scripts¥GeomOutProc.vbs 

19. Parse Scriptボタンをクリックします。Scriptからプロシージャと引数を検出してリスト
アップしてくれます。Script Procedure には”OutValue”が、Parameters には filename
の引数がリストアップされます。 

20. Valueのボックスをクリック（ボックスの右寄りの部分）して表示されるプルダウンから
Prompt On Runを選択します。これによって、この Scriptの実行時には引数の入力を促
す入力ボックスが表示されることになります。 
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21. OKをクリックすると GeomOutProcボタンが登録されます。 
22. GeomOutProc ボタンをクリックしてみて下さい。ファイル名を入力するダイアログが表
示されます。ファイル名を入力し、OKをクリックするとファイルに出力されます。 
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